What’s Vulnerable › Vulnerabilities
CVE-2024-6386: WPML Multilingual CMS <= 4.6.12 - Authenticated (Contributor+) Remote Code Execution via Twig Server-Side Template Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 25.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-21 · updated 2026-06-17
- Weakness: CWE-1336
Description
The WPML plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.6.12 via Twig Server-Side Template Injection. This is due to missing input validation and sanitization on the render function. This makes it possible for authenticated attackers, with Contributor-level access and above, to execute code on the server.
Affected products
- OnTheGoSystems Ltd. WPML Multilingual CMS (WordPress plugin): before 4.6.13 — fixed in 4.6.13
How to fix
Upgrade to a fixed version: OnTheGoSystems Ltd. WPML Multilingual CMS (WordPress plugin) 4.6.13. Check the vendor advisory for mitigations.
References
- https://sec.stealthcopter.com/wpml-rce-via-twig-ssti/
- https://wpml.org/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f7fc91cc-e529-4362-8269-bf7ee0766e1e?source=cve
Get alerted when CVE-2024-6386 or the next vulnerability affects your stack