What’s Vulnerable › Vulnerabilities
CVE-2024-6390: Quiz and Survey Master (QSM) < 9.1.0 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-03 · updated 2026-06-17
- Weakness: CWE-79
Description
The Quiz and Survey Master (QSM) WordPress plugin before 9.1.0 does not properly sanitise and escape some of its Quizz settings, which could allow high privilege users such as contributor to perform Stored Cross-Site Scripting attacks
Affected products
- ExpressTech Quiz And Survey Master: before 9.1.0 — fixed in 9.1.0
How to fix
Upgrade to a fixed version: ExpressTech Quiz And Survey Master 9.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-6390 or the next vulnerability affects your stack