What’s Vulnerable › Vulnerabilities
CVE-2024-6392: Image Optimizer, Resizer and CDN – Sirv <= 7.2.7 - Authenticated(Subscriber+) Missing Authorization to Plugin Settings Update
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-11 · updated 2026-06-17
- Weakness: CWE-862
Description
The Image Optimizer, Resizer and CDN – Sirv plugin for WordPress is vulnerable to unauthorized plugin settings modification due to missing capability checks on the plugin functions in all versions up to, and including, 7.2.7. This makes it possible for authenticated attackers, with Subscriber-level access and above, to change the connected Sirv account to an attacker-controlled one.
Affected products
- sirv Image Optimizer, Resizer and CDN – Sirv: before 7.2.8 — fixed in 7.2.8
How to fix
Upgrade to a fixed version: sirv Image Optimizer, Resizer and CDN – Sirv 7.2.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/sirv/tags/7.2.6/sirv.php#L5197
- https://plugins.trac.wordpress.org/browser/sirv/tags/7.2.6/sirv.php#L5338
- https://www.wordfence.com/threat-intel/vulnerabilities/id/229490c3-d820-4831-b105-a429512c2c60?source=cve
- https://plugins.trac.wordpress.org/browser/sirv/tags/7.2.6/sirv.php#L5197
- https://plugins.trac.wordpress.org/browser/sirv/tags/7.2.6/sirv.php#L5338
- https://www.wordfence.com/threat-intel/vulnerabilities/id/229490c3-d820-4831-b105-a429512c2c60?source=cve
Get alerted when CVE-2024-6392 or the next vulnerability affects your stack