What’s Vulnerable › Vulnerabilities
CVE-2024-6428: Limited DoS due to permitting creating users with user-defined IDs
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-03 · updated 2026-06-17
- Weakness: CWE-284
Description
Mattermost versions 9.8.0, 9.7.x <= 9.7.4, 9.6.x <= 9.6.2, 9.5.x <= 9.5.5 fail to prevent specifying a RemoteId when creating a new user which allows an attacker to specify both a remoteId and the user ID, resulting in creating a user with a user-defined user ID. This can cause some broken functionality in User Management such administrative actions against the user not working.
Affected products
- Mattermost App Framework: from 9.5.0 before 9.5.6; from 9.6.0 before 9.6.3; from 9.7.0 before 9.7.5; from 9.8.0 before 9.8.1 — fixed in 9.5.6, 9.6.3, 9.7.5, 9.8.1
How to fix
Upgrade to a fixed version: Mattermost App Framework 9.5.6, 9.6.3, 9.7.5, 9.8.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-6428 or the next vulnerability affects your stack