What’s Vulnerable › Vulnerabilities
CVE-2024-6446: Business Logic Errors in GitLab
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-12 · updated 2026-06-17
- Weakness: CWE-840
Description
An issue has been discovered in GitLab affecting all versions starting from 17.1 to 17.1.7, 17.2 prior to 17.2.5 and 17.3 prior to 17.3.2. A crafted URL could be used to trick a victim to trust an attacker controlled application.
Affected products
- GitLab: from 17.1.0 before 17.1.7; from 17.2.0 before 17.2.5; from 17.3.0 before 17.3.2 — fixed in 17.1.7, 17.2.5, 17.3.2
How to fix
Upgrade to a fixed version: GitLab 17.1.7, 17.2.5, 17.3.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/gitlab/-/issues/470144
- https://hackerone.com/reports/2573481
- https://about.gitlab.com/releases/2024/09/11/patch-release-gitlab-17-3-2-released/
Get alerted when CVE-2024-6446 or the next vulnerability affects your stack