What’s Vulnerable › Vulnerabilities
CVE-2024-6450: Reflected XSS in HyperView Geoportal Toolkit
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-28 · updated 2026-06-17
- Weakness: CWE-79
Description
HyperView Geoportal Toolkit in versions lower than 8.5.0 is vulnerable to Reflected Cross-Site Scripting (XSS). An unauthenticated attacker might trick somebody into using a crafted URL, which will cause a script to be run in user's browser.
Affected products
- HyperView Geoportal Toolkit: before 8.5.0 — fixed in 8.5.0
How to fix
Upgrade to a fixed version: HyperView Geoportal Toolkit 8.5.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-6450 or the next vulnerability affects your stack