What’s Vulnerable › Vulnerabilities
CVE-2024-6451: AI Engine < 2.5.1 - Admin+ RCE
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-19 · updated 2026-06-17
- Weakness: CWE-532
Description
AI Engine < 2.4.3 is susceptible to remote-code-execution (RCE) via Log Poisoning. The AI Engine WordPress plugin before 2.5.1 fails to validate the file extension of "logs_path", allowing Administrators to change log filetypes from .log to .php.
Affected products
- AI Engine: before 2.4.3 — fixed in 2.4.3
How to fix
Upgrade to a fixed version: AI Engine 2.4.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-6451 or the next vulnerability affects your stack