What’s Vulnerable › Vulnerabilities
CVE-2024-6458: WooCommerce Product Table Lite <= 3.5.1 - Missing Authorization to (Subscriber+) Stored Cross-Site Scripting
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-27 · updated 2026-06-17
- Weakness: CWE-862
Description
The WooCommerce Product Table Lite plugin for WordPress is vulnerable to unauthorized post title modification due to a missing capability check on the wcpt_presets__duplicate_preset_to_table function in all versions up to, and including, 3.5.1. This makes it possible for authenticated attackers with subscriber access and above to change titles of arbitrary posts. Missing sanitization can lead to Stored Cross-Site Scripting when viewed by an admin via the WooCommerce Product Table.
Affected products
- WC Product Table WooCommerce Product Table Lite: before 3.8.6 — fixed in 3.8.6
How to fix
Upgrade to a fixed version: WC Product Table WooCommerce Product Table Lite 3.8.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wc-product-table-lite/trunk/presets/presets.php#L120
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3125858%40wc-product-table-lite&new=3125858%40wc-product-table-lite&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e06fb465-4c72-49a8-af35-ff6d629ff9a0?source=cve
- https://plugins.trac.wordpress.org/browser/wc-product-table-lite/trunk/presets/presets.php#L120
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3125858%40wc-product-table-lite&new=3125858%40wc-product-table-lite&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e06fb465-4c72-49a8-af35-ff6d629ff9a0?source=cve
Get alerted when CVE-2024-6458 or the next vulnerability affects your stack