What’s Vulnerable › Vulnerabilities
CVE-2024-6472: Ability to trust not validated macro signatures removed in high security mode
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-05 · updated 2026-06-17
- Weakness: CWE-295
Description
Certificate Validation user interface in LibreOffice allows potential vulnerability. Signed macros are scripts that have been digitally signed by the developer using a cryptographic signature. When a document with a signed macro is opened a warning is displayed by LibreOffice before the macro is executed. Previously if verification failed the user could fail to understand the failure and choose to enable the macros anyway. This issue affects LibreOffice: from 24.2 before 24.2.5.
Affected products
- The Document Foundation LibreOffice: from 24.2.0.0 before 24.2.5.1 — fixed in 24.2.5.1
How to fix
Upgrade to a fixed version: The Document Foundation LibreOffice 24.2.5.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-6472 or the next vulnerability affects your stack