What’s Vulnerable › Vulnerabilities
CVE-2024-6477: UsersWP < 1.2.12 - Users Information Disclosure
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-03 · updated 2026-06-17
Description
The UsersWP WordPress plugin before 1.2.12 uses predictable filenames when an admin generates an export, which could allow unauthenticated attackers to download them and retrieve sensitive information such as IP, username, and email address
Affected products
- stiofansisland UsersWP – Front-end login form, User Registration, User Profile & Members Directory plugin for WP: before 1.2.12 — fixed in 1.2.12
How to fix
Upgrade to a fixed version: stiofansisland UsersWP – Front-end login form, User Registration, User Profile & Members Directory plugin for WP 1.2.12. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-6477 or the next vulnerability affects your stack