What’s Vulnerable › Vulnerabilities
CVE-2024-6481: Search Filter Pro < 2.5.18 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The Search & Filter Pro WordPress plugin before 2.5.18 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Search & Filter: before 2.5.18 — fixed in 2.5.18
How to fix
Upgrade to a fixed version: Search & Filter 2.5.18. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-6481 or the next vulnerability affects your stack