What’s Vulnerable › Vulnerabilities
CVE-2024-6482: Login with phone number <= 1.7.49 - Authenticated (Subscriber+) Authorization Bypass to Privilege Escalation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-14 · updated 2026-06-17
- Weakness: CWE-269
Description
The Login with phone number plugin for WordPress is vulnerable to privilege escalation in all versions up to, and including, 1.7.49. This is due to a lack of validation and missing capability check on user-supplied data in the 'lwp_update_password_action' function. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update their role to any other role, including Administrator. The vulnerability was partially patched in version 1.7.40. The login with phone number pro plugin was required to exploit the vulnerability in versions 1.7.40 - 1.7.49.
Affected products
- Hamid Alinia Login with phone number: from 1.7.40 before 1.7.50 — fixed in 1.7.50
How to fix
Upgrade to a fixed version: Hamid Alinia Login with phone number 1.7.50. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/login-with-phone-number/trunk/login-with-phonenumber.php#L3803
- https://plugins.trac.wordpress.org/changeset/3129185/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/de7cde2c-142c-4004-9302-be335265d87d?source=cve
Get alerted when CVE-2024-6482 or the next vulnerability affects your stack