What’s Vulnerable › Vulnerabilities
CVE-2024-6497: SEO Plugin by Squirrly SEO <= 12.3.19 - Authenticated (Contributor+) SQL Injection via url Parameter
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 11.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-20 · updated 2026-06-17
- Weakness: CWE-89
Description
The SEO Plugin by Squirrly SEO plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘url’ parameter in all versions up to, and including, 12.3.19 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. CVE-2024-43286 appears to be a duplicate of this issue.
Affected products
- SEO Squirrly SEO Plugin by Squirrly SEO: before 12.3.20 — fixed in 12.3.20
How to fix
Upgrade to a fixed version: SEO Squirrly SEO Plugin by Squirrly SEO 12.3.20. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/squirrly-seo/trunk/controllers/Api.php#L267
- https://plugins.trac.wordpress.org/changeset/3121853/
- https://wordpress.org/plugins/squirrly-seo/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/bb3aa613-8f34-4d96-8ddf-41fcdcf65c59?source=cve
- https://nowotarski.info/wordpress-nonce-authorization/
- https://plugins.trac.wordpress.org/browser/squirrly-seo/trunk/controllers/Api.php#L267
- https://plugins.trac.wordpress.org/changeset/3121853/
- https://wordpress.org/plugins/squirrly-seo/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/bb3aa613-8f34-4d96-8ddf-41fcdcf65c59?source=cve
Get alerted when CVE-2024-6497 or the next vulnerability affects your stack