What’s Vulnerable › Vulnerabilities
CVE-2024-6498: CollectChat < 2.4.4 - Admin+ XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The Chatbot for WordPress by Collect.chat ⚡️ WordPress plugin before 2.4.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed
Affected products
- Chatbot for WordPress by Collect.chat ⚡️: before 2.4.4 — fixed in 2.4.4
How to fix
Upgrade to a fixed version: Chatbot for WordPress by Collect.chat ⚡️ 2.4.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-6498 or the next vulnerability affects your stack