What’s Vulnerable › Vulnerabilities
CVE-2024-6499: WordPress Button Plugin MaxButtons <= 9.7.8 - Full Path Disclosure
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-24 · updated 2026-06-17
- Weakness: CWE-200
Description
The WordPress Button Plugin MaxButtons plugin for WordPress is vulnerable to information exposure in all versions up to, and including, 9.7.8. This makes it possible for unauthenticated attackers to obtain the full path to instances, which they may be able to use in combination with other vulnerabilities or to simplify reconnaissance work. On its own, this information is of very limited use.
Affected products
- maxfoundry MaxButtons – Create buttons: before 9.8.0 — fixed in 9.8.0
How to fix
Upgrade to a fixed version: maxfoundry MaxButtons – Create buttons 9.8.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/maxbuttons/trunk/assets/libraries/font-awesome-5/convert.php
- https://plugins.trac.wordpress.org/changeset/3140369/maxbuttons/tags/9.8.0/assets/libraries/font-awesome-5/convert.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/fdd0694c-ea7e-4cf8-a8d8-82a2b02fecdf?source=cve
Get alerted when CVE-2024-6499 or the next vulnerability affects your stack