What’s Vulnerable › Vulnerabilities

CVE-2024-6502: Incorrect Provision of Specified Functionality in GitLab

Description

An issue was discovered in GitLab CE/EE affecting all versions starting from 8.2 prior to 17.1.6 starting from 17.2 prior to 17.2.4, and starting from 17.3 prior to 17.3.1, which allows an attacker to create a branch with the same name as a deleted tag.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.1.6, 17.2.4, 17.3.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-6502 or the next vulnerability affects your stack