What’s Vulnerable › Vulnerabilities
CVE-2024-6509
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-10 · updated 2026-06-17
- Weakness: CWE-155
Description
Marinus Pfund, member of the AXIS OS Bug Bounty Program, has found the VAPIX API alwaysmulti.cgi was vulnerable for file globbing which could lead to resource exhaustion of the Axis device. Axis has released patched AXIS OS versions for the highlighted flaw. Please refer to the Axis security advisory for more information and solution.
Affected products
- Axis Communications AB AXIS OS: from 6.50.0 before 6.50.5.19; from 7.0.0 before 8.40.59; from 9.0.0 before 9.80.78; from 10.0.0 before 10.12.249; from 11.0.0 before 11.11.93 — fixed in 10.12.249, 11.11.93, 6.50.5.19, 8.40.59, 9.80.78
How to fix
Upgrade to a fixed version: Axis Communications AB AXIS OS 10.12.249, 11.11.93, 6.50.5.19, 8.40.59. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-6509 or the next vulnerability affects your stack