What’s Vulnerable › Vulnerabilities
CVE-2024-6522: Modern Events Calendar <= 7.12.1 - Authenticated (Subscriber+) Server Side Request Forgery
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-07 · updated 2026-06-17
- Weakness: CWE-918
Description
The Modern Events Calendar plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 7.12.1 via the 'mec_fes_form' AJAX function. This makes it possible for authenticated attackers, with Subscriber-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.
Affected products
- Webnus Modern Events Calendar: before 7.13.0 — fixed in 7.13.0
- Modern Events Calendar Lite: before 7.13.0 — fixed in 7.13.0
How to fix
Upgrade to a fixed version: Webnus Modern Events Calendar 7.13.0; Modern Events Calendar Lite 7.13.0. Check the vendor advisory for mitigations.
References
- https://mec.webnus.net/change-log/
- https://plugins.trac.wordpress.org/browser/modern-events-calendar-lite/trunk/app/features/fes.php#L54
- https://wordpress.org/plugins/modern-events-calendar-lite/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/00bf8f2f-6ab4-4430-800b-5b97abe7589e?source=cve
Get alerted when CVE-2024-6522 or the next vulnerability affects your stack