What’s Vulnerable › Vulnerabilities
CVE-2024-6530: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-10 · updated 2026-06-17
- Weakness: CWE-79
Description
A cross-site scripting issue has been discovered in GitLab affecting all versions starting from 17.1 prior 17.2.9, starting from 17.3 prior to 17.3.5, and starting from 17.4 prior to 17.4.2. When adding a authorizing an application, it can be made to render as HTML under specific circumstances.
Affected products
- GitLab: from 17.1.0 before 17.2.9; from 17.3.0 before 17.3.5; from 17.4.0 before 17.4.2 — fixed in 17.2.9, 17.3.5, 17.4.2
How to fix
Upgrade to a fixed version: GitLab 17.2.9, 17.3.5, 17.4.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-6530 or the next vulnerability affects your stack