What’s Vulnerable › Vulnerabilities
CVE-2024-6582: Broken Access Control in lunary-ai/lunary
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-13 · updated 2026-06-17
- Weakness: CWE-306
Description
A broken access control vulnerability exists in the latest version of lunary-ai/lunary. The `saml.ts` file allows a user from one organization to update the Identity Provider (IDP) settings and view the SSO metadata of another organization. This vulnerability can lead to unauthorized access and potential account takeover if the email of a user in the target organization is known.
Affected products
- lunary-ai/lunary: before 1.4.9 — fixed in 1.4.9
How to fix
Upgrade to a fixed version: lunary-ai/lunary 1.4.9. Check the vendor advisory for mitigations.
References
- https://github.com/lunary-ai/lunary/commit/1f043d8798ad87346dfe378eea723bff78ad7433
- https://huntr.com/bounties/251d138c-3911-4a81-96e5-5a4ab59a0b59
Get alerted when CVE-2024-6582 or the next vulnerability affects your stack