What’s Vulnerable › Vulnerabilities
CVE-2024-6585
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-30 · updated 2026-06-17
- Weakness: CWE-79
Description
Multiple stored cross-site scripting (“XSS”) vulnerabilities in the markdown dashboard and dashboard comment functionality of Lightdash version 0.1024.6 allows remote authenticated threat actors to inject malicious scripts into vulnerable web pages. A threat actor could potentially exploit this vulnerability to store malicious JavaScript which executes in the context of a user’s session with the application.
Affected products
- lightdash: from 0.1024.6 before 0.1042.2 — fixed in 0.1042.2
How to fix
Upgrade to a fixed version: lightdash 0.1042.2. Check the vendor advisory for mitigations.
References
- https://github.com/google/security-research/security/advisories/GHSA-6529-6jv3-66q2
- https://github.com/lightdash/lightdash
- https://github.com/lightdash/lightdash/pull/9359
- https://github.com/lightdash/lightdash/pull/9510
- https://github.com/lightdash/lightdash/releases/tag/0.1042.2
- https://patch-diff.githubusercontent.com/raw/lightdash/lightdash/pull/9359.patch
- https://patch-diff.githubusercontent.com/raw/lightdash/lightdash/pull/9510.patch
- https://www.cve.org/CVERecord?id=CVE-2024-6585
Get alerted when CVE-2024-6585 or the next vulnerability affects your stack