What’s Vulnerable › Vulnerabilities
CVE-2024-6596: Endress+Hauser: Multiple products are vulnerable to code injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-10 · updated 2026-06-17
- Weakness: CWE-94
Description
An unauthenticated remote attacker can run malicious c# code included in curve files and execute commands in the users context.
Affected products
- Endress+Hauser Echo Curve Viewer: before 6.0.0 — fixed in 6.0.0
- Endress Field Xpert Smt50 Firmware: all versions
- Endress Field Xpert Smt70 Firmware: all versions
- Endress Field Xpert Smt77 Firmware: all versions
- Endress Field Xpert Smt79 Firmware: all versions
- Endress Fieldcare Sfe500 Package: before 1.40.1 — fixed in 1.40.1
How to fix
Upgrade to a fixed version: Endress+Hauser Echo Curve Viewer 6.0.0; Endress Fieldcare Sfe500 Package 1.40.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-6596 or the next vulnerability affects your stack