What’s Vulnerable › Vulnerabilities
CVE-2024-6620
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-29 · updated 2026-06-17
- Weakness: CWE-79
Description
Honeywell PC42t, PC42tp, and PC42d Printers, T10.19.020016 to T10.20.060398, contain a cross-site scripting vulnerability. A(n) attacker could potentially inject malicious code which may lead to information disclosure, session theft, or client-side request forgery. Honeywell recommends updating to the most recent version of this firmware, PC42 Printer Firmware Version 20.6 T10.20.060398.
Affected products
- Honeywell PC42t, PC42tp, and PC42d (Common Firmware): from T10.19.020016 before T10.20.060398 — fixed in T10.20.060398
How to fix
Upgrade to a fixed version: Honeywell PC42t, PC42tp, and PC42d (Common Firmware) T10.20.060398. Check the vendor advisory for mitigations.
References
- https://sps.honeywell.com/us/en/support/productivity/cyber-security-notifications
- https://sps.honeywell.com/us/en/support/productivity/cyber-security-notifications
Get alerted when CVE-2024-6620 or the next vulnerability affects your stack