What’s Vulnerable › Vulnerabilities
CVE-2024-6624: JSON API User <= 3.9.3 - Unauthenticated Privilege Escalation
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-11 · updated 2026-06-17
- Weakness: CWE-269
Description
The JSON API User plugin for WordPress is vulnerable to privilege escalation in all versions up to, and including, 3.9.3. This is due to improper controls on custom user meta fields. This makes it possible for unauthenticated attackers to register as administrators on the site. The plugin requires the JSON API plugin to also be installed.
Affected products
- parorrey JSON API User: before 3.9.4 — fixed in 3.9.4
How to fix
Upgrade to a fixed version: parorrey JSON API User 3.9.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/json-api-user/trunk/controllers/User.php#L187
- https://plugins.trac.wordpress.org/browser/json-api-user/trunk/controllers/User.php#L51
- https://plugins.trac.wordpress.org/changeset/3115185/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a4a26f60-5912-4d4a-8ef8-e4357c1fb1ff?source=cve
- https://plugins.trac.wordpress.org/browser/json-api-user/trunk/controllers/User.php#L187
- https://plugins.trac.wordpress.org/browser/json-api-user/trunk/controllers/User.php#L51
- https://plugins.trac.wordpress.org/changeset/3115185/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a4a26f60-5912-4d4a-8ef8-e4357c1fb1ff?source=cve
Get alerted when CVE-2024-6624 or the next vulnerability affects your stack