What’s Vulnerable › Vulnerabilities
CVE-2024-6635: WooCommerce - Social Login <= 2.7.3 - Unauthenticated Authentication Bypass
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-20 · updated 2026-06-17
- Weakness: CWE-288
Description
The WooCommerce - Social Login plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 2.7.3. This is due to insufficient controls in the 'woo_slg_login_email' function. This makes it possible for unauthenticated attackers to log in as any existing user on the site, excluding an administrator, if they know the email of user.
Affected products
- WPWeb WooCommerce - Social Login: before 2.7.4 — fixed in 2.7.4
How to fix
Upgrade to a fixed version: WPWeb WooCommerce - Social Login 2.7.4. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/social-login-wordpress-woocommerce-plugin/8495883
- https://www.wordfence.com/threat-intel/vulnerabilities/id/37836722-eb25-4393-8cdf-91057642ba3f?source=cve
- https://codecanyon.net/item/social-login-wordpress-woocommerce-plugin/8495883
- https://www.wordfence.com/threat-intel/vulnerabilities/id/37836722-eb25-4393-8cdf-91057642ba3f?source=cve
Get alerted when CVE-2024-6635 or the next vulnerability affects your stack