What’s Vulnerable › Vulnerabilities
CVE-2024-6637: WooCommerce - Social Login <= 2.7.3 - Unauthenticated Privilege Escalation via One-Time Password
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-20 · updated 2026-06-17
- Weakness: CWE-305
Description
The WooCommerce - Social Login plugin for WordPress is vulnerable to unauthenticated privilege escalation in all versions up to, and including, 2.7.3. This is due to a lack of brute force controls on a weak one-time password. This makes it possible for unauthenticated attackers to brute force the one-time password for any user, except an Administrator, if they know the email of user.
Affected products
- WPWeb WooCommerce - Social Login: before 2.7.4 — fixed in 2.7.4
How to fix
Upgrade to a fixed version: WPWeb WooCommerce - Social Login 2.7.4. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/social-login-wordpress-woocommerce-plugin/8495883
- https://www.wordfence.com/threat-intel/vulnerabilities/id/10d92d5e-1c23-4f6a-bfab-0756876190a5?source=cve
- https://codecanyon.net/item/social-login-wordpress-woocommerce-plugin/8495883
- https://www.wordfence.com/threat-intel/vulnerabilities/id/10d92d5e-1c23-4f6a-bfab-0756876190a5?source=cve
Get alerted when CVE-2024-6637 or the next vulnerability affects your stack