What’s Vulnerable › Vulnerabilities
CVE-2024-6641: WP Hardening – Fix Your WordPress Security <= 1.2.6 - Unauthenticated Security Feature Bypass to Username Enumeration
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-18 · updated 2026-06-17
- Weakness: CWE-185
Description
The WP Hardening – Fix Your WordPress Security plugin for WordPress is vulnerable to Security Feature Bypass in all versions up to, and including, 1.2.6. This is due to use of an incorrect regular expression within the "Stop User Enumeration" feature. This makes it possible for unauthenticated attackers to bypass intended security restrictions and expose site usernames.
Affected products
- WP Hardening – Fix Your WordPress Security: before 1.2.7 — fixed in 1.2.7
How to fix
Upgrade to a fixed version: WP Hardening – Fix Your WordPress Security 1.2.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3151308/wp-security-hardening
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7a52a278-1729-4027-8a00-e9804fa6698b?source=cve
Get alerted when CVE-2024-6641 or the next vulnerability affects your stack