What’s Vulnerable › Vulnerabilities
CVE-2024-6648: Path Traversal in AP Page Builder
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-08 · updated 2026-06-17
- Weakness: CWE-22
Description
Absolute Path Traversal vulnerability in AP Page Builder versions prior to 4.0.0 could allow an unauthenticated remote user to modify the 'product_item_path' within the 'config' JSON file, allowing them to read any file on the system.
Affected products
- Apollo Theme AP Page Builder: before 4.0.0 — fixed in 4.0.0
How to fix
Upgrade to a fixed version: Apollo Theme AP Page Builder 4.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-6648 or the next vulnerability affects your stack