What’s Vulnerable › Vulnerabilities
CVE-2024-6662: CSRF in MegaBIP
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-10 · updated 2026-06-17
- Weakness: CWE-352
Description
Websites managed by MegaBIP in versions below 5.15 are vulnerable to Cross-Site Request Forgery (CSRF) as the form available under "/edytor/index.php?id=7,7,0" lacks protection mechanisms. A user could be tricked into visiting a malicious website, which would send POST request to this endpoint. If the victim is a logged in administrator, this could lead to creation of new accounts and granting of administrative permissions.
Affected products
- Jan Syski MegaBIP: before 5.15 — fixed in 5.15
How to fix
Upgrade to a fixed version: Jan Syski MegaBIP 5.15. Check the vendor advisory for mitigations.
References
- https://cert.pl/en/posts/2024/09/CVE-2024-6662
- https://megabip.pl/
- https://www.gov.pl/web/cyfryzacja/rekomendacja-pelnomocnika-rzadu-ds-cyberbezpieczenstwa-dotyczaca-biuletynow-informacji-publicznej
Get alerted when CVE-2024-6662 or the next vulnerability affects your stack