What’s Vulnerable › Vulnerabilities
CVE-2024-6669: AI ChatBot for WordPress – WPBot <= 5.5.7 - Authenticated (Administrator+) Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The AI ChatBot for WordPress – WPBot plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 5.5.7 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
Affected products
- quantumcloud WPBot – AI ChatBot for Live Support, Lead Generation, AI Services: before 5.5.8 — fixed in 5.5.8
How to fix
Upgrade to a fixed version: quantumcloud WPBot – AI ChatBot for Live Support, Lead Generation, AI Services 5.5.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/chatbot/trunk/admin_ui.php#L2211
- https://plugins.trac.wordpress.org/browser/chatbot/trunk/admin_ui.php#L755
- https://plugins.trac.wordpress.org/changeset/3119022/
- https://wordpress.org/plugins/chatbot/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ce23efed-fe21-486a-ab3b-9ed0dd26a971?source=cve
- https://plugins.trac.wordpress.org/browser/chatbot/trunk/admin_ui.php#L2211
- https://plugins.trac.wordpress.org/browser/chatbot/trunk/admin_ui.php#L755
- https://plugins.trac.wordpress.org/changeset/3119022/
- https://wordpress.org/plugins/chatbot/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ce23efed-fe21-486a-ab3b-9ed0dd26a971?source=cve
Get alerted when CVE-2024-6669 or the next vulnerability affects your stack