What’s Vulnerable › Vulnerabilities
CVE-2024-6677
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-12 · updated 2026-06-17
- Weakness: CWE-269
Description
Privilege escalation in uberAgent
Affected products
- Citrix uberAgent: before 7.2.1 — fixed in 7.2.1
- Citrix uberAgent: before 7.2.1 — fixed in 7.2.1
- Citrix uberAgent: from 7.2 before 1 — fixed in 1
How to fix
Upgrade to a fixed version: Citrix uberAgent 7.2.1; Citrix uberAgent 7.2.1; Citrix uberAgent 1. Check the vendor advisory for mitigations.
References
- https://support.citrix.com/article/CTX691103/citrix-uberagent-security-bulletin-for-cve20246677
- https://support.citrix.com/external/article/691103/citrix-uberagent-security-bulletin-for-c.html
- https://support.citrix.com/article/CTX691103/citrix-uberagent-security-bulletin-for-cve20246677
Get alerted when CVE-2024-6677 or the next vulnerability affects your stack