What’s Vulnerable › Vulnerabilities

CVE-2024-6678: Authentication Bypass by Spoofing in GitLab

Description

An issue was discovered in GitLab CE/EE affecting all versions starting from 8.14 prior to 17.1.7, starting from 17.2 prior to 17.2.5, and starting from 17.3 prior to 17.3.2, which allows an attacker to trigger a pipeline as an arbitrary user under certain circumstances.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.1.7, 17.2.5, 17.3.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-6678 or the next vulnerability affects your stack