What’s Vulnerable › Vulnerabilities
CVE-2024-6687: CTT Expresso para WooCommerce <= 3.2.12 - Information Exposure via Unprotected Directory
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-01 · updated 2026-06-17
- Weakness: CWE-200
Description
The CTT Expresso para WooCommerce plugin for WordPress is vulnerable to sensitive information exposure in all versions up to and including 3.2.12 via the /wp-content/uploads/cepw directory. The generated .pdf and log files are publicly accessible and contain sensitive information such as sender and receiver names, phone numbers, physical addresses, and email addresses
Affected products
- this.functional CTT Expresso para WooCommerce: before 3.2.13 — fixed in 3.2.13
How to fix
Upgrade to a fixed version: this.functional CTT Expresso para WooCommerce 3.2.13. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3127496%40ctt-expresso-para-woocommerce&new=3127496%40ctt-expresso-para-woocommerce&sfp_email=&sfph_mail=#file25
- https://www.wordfence.com/threat-intel/vulnerabilities/id/13088645-8233-40fb-8755-cbdf44c0eaf7?source=cve
Get alerted when CVE-2024-6687 or the next vulnerability affects your stack