What’s Vulnerable › Vulnerabilities
CVE-2024-6704: Comments – wpDiscuz <= 7.6.21 - Unauthenticated HTML Injection
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The Comments – wpDiscuz plugin for WordPress is vulnerable to HTML Injection in all versions up to, and including, 7.6.21. This is due to a lack of filtering of HTML tags in comments. This makes it possible for unauthenticated attackers to add HTML such as hyperlinks to comments when rich editing is disabled.
Affected products
- gVectors wpDiscuz: before 7.6.22 — fixed in 7.6.22
How to fix
Upgrade to a fixed version: gVectors wpDiscuz 7.6.22. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wpdiscuz/trunk/class.WpdiscuzCore.php#L335
- https://plugins.trac.wordpress.org/changeset/3124810/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/fa3501a4-7975-4f90-8037-f8a06c293c07?source=cve
Get alerted when CVE-2024-6704 or the next vulnerability affects your stack