What’s Vulnerable › Vulnerabilities
CVE-2024-6708: Profile Builder <= 3.12.0 - Admin+ Stored Cross Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The User Profile Builder WordPress plugin before 3.12.2 does not sanitise and escape some parameters before outputting its content on the admin area, which allows Admin+ users to perform Cross-Site Scripting attacks.
Affected products
- cozmoslabs User Profile Builder – Beautiful User Registration Forms, User Profiles & User Role Editor: before 3.12.2 — fixed in 3.12.2
How to fix
Upgrade to a fixed version: cozmoslabs User Profile Builder – Beautiful User Registration Forms, User Profiles & User Role Editor 3.12.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b6822bd9-f9f9-41a4-ad19-019b1f03bd4c/
- https://wpscan.com/vulnerability/b6822bd9-f9f9-41a4-ad19-019b1f03bd4c/
Get alerted when CVE-2024-6708 or the next vulnerability affects your stack