What’s Vulnerable › Vulnerabilities
CVE-2024-6709: Sync Post With Other Site <= 1.6 - Missing Authorization to Authenticated (Subscriber+) Post Creation and Update
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-03 · updated 2026-06-17
- Weakness: CWE-862
Description
The Sync Post With Other Site plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'sps_add_update_post' function in all versions up to, and including, 1.6. This makes it possible for authenticated attackers, with Subscriber-level access and above, to create new draft posts and update existing posts.
Affected products
- Kamlesh Parmar Sync Post With Other Site: before 1.7 — fixed in 1.7
How to fix
Upgrade to a fixed version: Kamlesh Parmar Sync Post With Other Site 1.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/sync-post-with-other-site/trunk/includes/sps_sync.class.php#L231
- https://plugins.trac.wordpress.org/changeset/3128945/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3d97eee1-0f72-4dd3-998a-acb454fa5e8a?source=cve
Get alerted when CVE-2024-6709 or the next vulnerability affects your stack