What’s Vulnerable › Vulnerabilities
CVE-2024-6710: Ditty < 3.1.45 - Author+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The Ditty WordPress plugin before 3.1.45 does not sanitise and escape some parameters, which could allow users with a role as low as Contributor to perform Cross-Site Scripting attacks.
Affected products
- Ditty: before 3.1.46 — fixed in 3.1.46
How to fix
Upgrade to a fixed version: Ditty 3.1.46. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-6710 or the next vulnerability affects your stack