What’s Vulnerable › Vulnerabilities
CVE-2024-6714
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-23 · updated 2026-06-17
- Weakness: CWE-73
Description
An issue was discovered in provd before version 0.1.5 with a setuid binary, which allows a local attacker to escalate their privilege.
Affected products
- Canonical Ltd. Ubuntu Desktop Provision: before 0.1.5 — fixed in 0.1.5
How to fix
Upgrade to a fixed version: Canonical Ltd. Ubuntu Desktop Provision 0.1.5. Check the vendor advisory for mitigations.
References
- https://bugs.launchpad.net/ubuntu/+source/provd/+bug/2071574
- https://github.com/canonical/ubuntu-desktop-provision/commit/8d9086de0f82894ff27a9e429ff4f45231020092
- https://www.cve.org/CVERecord?id=CVE-2024-6714
- https://bugs.launchpad.net/ubuntu/+source/provd/+bug/2071574
- https://github.com/canonical/ubuntu-desktop-provision/commit/8d9086de0f82894ff27a9e429ff4f45231020092
- https://www.cve.org/CVERecord?id=CVE-2024-6714
Get alerted when CVE-2024-6714 or the next vulnerability affects your stack