What’s Vulnerable › Vulnerabilities
CVE-2024-6723: AI Engine < 2.4.8 - Admin+ SQLi
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-13 · updated 2026-06-17
- Weakness: CWE-89
Description
The AI Engine WordPress plugin before 2.4.8 does not properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by admin users when viewing chatbot discussions.
Affected products
- AI Engine: before 2.4.8 — fixed in 2.4.8
How to fix
Upgrade to a fixed version: AI Engine 2.4.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-6723 or the next vulnerability affects your stack