What’s Vulnerable › Vulnerabilities
CVE-2024-6724: Generate Images – Magic Post Thumbnail < 5.2.8 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Generate Images WordPress plugin before 5.2.8 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Magic Post Thumbnail: before 5.2.8 — fixed in 5.2.8
How to fix
Upgrade to a fixed version: Magic Post Thumbnail 5.2.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-6724 or the next vulnerability affects your stack