What’s Vulnerable › Vulnerabilities
CVE-2024-6750: Social Auto Poster <= 5.3.14 - Missing Authorization via Multiple Functions
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-24 · updated 2026-06-17
- Weakness: CWE-862
Description
The Social Auto Poster plugin for WordPress is vulnerable to unauthorized access, modification, and loss of data due to a missing capability check on multiple functions in all versions up to, and including, 5.3.14. This makes it possible for unauthenticated attackers to add, modify, or delete post meta and plugin options.
Affected products
- WPWeb Social Auto Poster: before 5.3.15 — fixed in 5.3.15
How to fix
Upgrade to a fixed version: WPWeb Social Auto Poster 5.3.15. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/social-auto-poster-wordpress-scheduler-marketing-plugin/5754169
- https://www.wordfence.com/threat-intel/vulnerabilities/id/36b58a4f-0761-4775-9010-9c77d4019c44?source=cve
- https://codecanyon.net/item/social-auto-poster-wordpress-scheduler-marketing-plugin/5754169
- https://www.wordfence.com/threat-intel/vulnerabilities/id/36b58a4f-0761-4775-9010-9c77d4019c44?source=cve
Get alerted when CVE-2024-6750 or the next vulnerability affects your stack