What’s Vulnerable › Vulnerabilities
CVE-2024-6751: Social Auto Poster <= 5.3.14 - Cross-Site Request Forgery via Multiple Functions
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-24 · updated 2026-06-17
- Weakness: CWE-352
Description
The Social Auto Poster plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 5.3.14. This is due to missing or incorrect nonce validation on multiple functions. This makes it possible for unauthenticated attackers to add, modify, or delete post meta and plugin options.
Affected products
- WPWeb Social Auto Poster: before 5.3.15 — fixed in 5.3.15
How to fix
Upgrade to a fixed version: WPWeb Social Auto Poster 5.3.15. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/social-auto-poster-wordpress-scheduler-marketing-plugin/5754169
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d7aceccc-7004-42f2-b085-eade9c45141c?source=cve
- https://codecanyon.net/item/social-auto-poster-wordpress-scheduler-marketing-plugin/5754169
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d7aceccc-7004-42f2-b085-eade9c45141c?source=cve
Get alerted when CVE-2024-6751 or the next vulnerability affects your stack