What’s Vulnerable › Vulnerabilities
CVE-2024-6752: Social Auto Poster <= 5.3.14 - Authenticated (Subscriber+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-24 · updated 2026-06-17
- Weakness: CWE-79
Description
The Social Auto Poster plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘wp_name’ parameter in the 'wpw_auto_poster_map_wordpress_post_type' AJAX function in all versions up to, and including, 5.3.14 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- WPWeb Social Auto Poster: before 5.3.15 — fixed in 5.3.15
How to fix
Upgrade to a fixed version: WPWeb Social Auto Poster 5.3.15. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/social-auto-poster-wordpress-scheduler-marketing-plugin/5754169
- https://www.wordfence.com/threat-intel/vulnerabilities/id/39b9e8a0-96bb-4b36-b4e8-ec9e3f137835?source=cve
- https://codecanyon.net/item/social-auto-poster-wordpress-scheduler-marketing-plugin/5754169
- https://www.wordfence.com/threat-intel/vulnerabilities/id/39b9e8a0-96bb-4b36-b4e8-ec9e3f137835?source=cve
Get alerted when CVE-2024-6752 or the next vulnerability affects your stack