What’s Vulnerable › Vulnerabilities
CVE-2024-6755: Social Auto Poster <= 5.3.14 - Missing Authorization to Unauthenticated Arbitrary Post Deletion
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-24 · updated 2026-06-17
- Weakness: CWE-862
Description
The Social Auto Poster plugin for WordPress is vulnerable to unauthorized modification and loss of data due to a missing capability check on the ‘wpw_auto_poster_quick_delete_multiple’ function in all versions up to, and including, 5.3.14. This makes it possible for unauthenticated attackers to delete arbitrary posts.
Affected products
- WPWeb Social Auto Poster: before 5.3.15 — fixed in 5.3.15
How to fix
Upgrade to a fixed version: WPWeb Social Auto Poster 5.3.15. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/social-auto-poster-wordpress-scheduler-marketing-plugin/5754169
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d9b1044d-6858-498f-9b89-352650061858?source=cve
- https://codecanyon.net/item/social-auto-poster-wordpress-scheduler-marketing-plugin/5754169
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d9b1044d-6858-498f-9b89-352650061858?source=cve
Get alerted when CVE-2024-6755 or the next vulnerability affects your stack