What’s Vulnerable › Vulnerabilities
CVE-2024-6757: Elementor <= 3.23.5 - Authenticated (Contributor+) Basic Information Exposure via get_image_alt Function
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-15 · updated 2026-06-17
- Weakness: CWE-200
Description
The Elementor Website Builder – More than Just a Page Builder plugin for WordPress is vulnerable to Basic Information Exposure in all versions up to, and including, 3.23.5 via the get_image_alt function. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract either excerpt data or titles of private or password-protected posts.
Affected products
- Elementor Website Builder: before 3.24.6 — fixed in 3.24.6
How to fix
Upgrade to a fixed version: Elementor Website Builder 3.24.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/elementor/tags/3.23.0/includes/controls/media.php#L413
- https://www.wordfence.com/threat-intel/vulnerabilities/id/96fa9ed7-6c13-4356-8a25-8a309be2b0e9?source=cve
Get alerted when CVE-2024-6757 or the next vulnerability affects your stack