What’s Vulnerable › Vulnerabilities
CVE-2024-6766: Shortcodes Ultimate Pro < 7.2.1 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The shortcodes-ultimate-pro WordPress plugin before 7.2.1 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- gn_themes WP Shortcodes Plugin — Shortcodes Ultimate: before 7.2.1 — fixed in 7.2.1
How to fix
Upgrade to a fixed version: gn_themes WP Shortcodes Plugin — Shortcodes Ultimate 7.2.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-6766 or the next vulnerability affects your stack