What’s Vulnerable › Vulnerabilities
CVE-2024-6799: YITH Essential Kit for WooCommerce #1 <= 2.34.0 - Missing Authorization to Authenticated (Subscriber+) Limited Plugin Install, Activation, and Deactivation
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-19 · updated 2026-06-17
- Weakness: CWE-862
Description
The YITH Essential Kit for WooCommerce #1 plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'activate_module', 'deactivate_module', and 'install_module' functions in all versions up to, and including, 2.34.0. This makes it possible for authenticated attackers, with Subscriber-level access and above, to install, activate, and deactivate plugins from a pre-defined list of available YITH plugins.
Affected products
- yithemes YITH Essential Kit for WooCommerce #1: before 2.35.0 — fixed in 2.35.0
How to fix
Upgrade to a fixed version: yithemes YITH Essential Kit for WooCommerce #1 2.35.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/yith-essential-kit-for-woocommerce-1/trunk/class-yith-jetpack.php#L425
- https://plugins.trac.wordpress.org/browser/yith-essential-kit-for-woocommerce-1/trunk/class-yith-jetpack.php#L457
- https://plugins.trac.wordpress.org/browser/yith-essential-kit-for-woocommerce-1/trunk/class-yith-jetpack.php#L487
- https://plugins.trac.wordpress.org/changeset/3120283/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ca497ffa-6306-46dc-895f-94f1d5236e28?source=cve
- https://plugins.trac.wordpress.org/browser/yith-essential-kit-for-woocommerce-1/trunk/class-yith-jetpack.php#L425
- https://plugins.trac.wordpress.org/browser/yith-essential-kit-for-woocommerce-1/trunk/class-yith-jetpack.php#L457
- https://plugins.trac.wordpress.org/browser/yith-essential-kit-for-woocommerce-1/trunk/class-yith-jetpack.php#L487
- https://plugins.trac.wordpress.org/changeset/3120283/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ca497ffa-6306-46dc-895f-94f1d5236e28?source=cve
Get alerted when CVE-2024-6799 or the next vulnerability affects your stack