What’s Vulnerable › Vulnerabilities
CVE-2024-6823: Media Library Assistant <= 3.18 - Authenticated (Author+) Arbitrary File Upload via mla-inline-edit-upload-scripts AJAX Action
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-13 · updated 2026-06-17
- Weakness: CWE-434
Description
The Media Library Assistant plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation involving the mla-inline-edit-upload-scripts AJAX action in all versions up to, and including, 3.18. This makes it possible for authenticated attackers, with Author-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible.
Affected products
- dglingren Media Library Assistant: before 3.19 — fixed in 3.19
How to fix
Upgrade to a fixed version: dglingren Media Library Assistant 3.19. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/media-library-assistant/trunk/includes/class-mla-settings.php#L32
- https://plugins.trac.wordpress.org/changeset/3133909/
- https://wordpress.org/plugins/media-library-assistant/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/9a446fe7-c97a-436e-b494-b924e6518297?source=cve
Get alerted when CVE-2024-6823 or the next vulnerability affects your stack