What’s Vulnerable › Vulnerabilities
CVE-2024-6827: HTTP Request Smuggling in benoitc/gunicorn
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-444
Description
Gunicorn version 21.2.0 does not properly validate the value of the 'Transfer-Encoding' header as specified in the RFC standards, which leads to the default fallback method of 'Content-Length,' making it vulnerable to TE.CL request smuggling. This vulnerability can lead to cache poisoning, data exposure, session manipulation, SSRF, XSS, DoS, data integrity compromise, security bypass, information leakage, and business logic abuse.
Affected products
- Pypi Gunicorn: before 22.0.0; 0.1, 0.10.0, 0.10.1, 0.11.0, 0.11.1, 0.11.2 (+79) — fixed in 22.0.0
- benoitc/gunicorn: through latest
How to fix
Upgrade to a fixed version: Pypi Gunicorn 22.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-6827 or the next vulnerability affects your stack