What’s Vulnerable › Vulnerabilities
CVE-2024-6835: Ivory Search – WordPress Search Plugin <= 5.5.6 - Information Exposure via AJAX Search Form
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-05 · updated 2026-06-17
- Weakness: CWE-200
Description
The Ivory Search – WordPress Search Plugin plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 5.5.6 via the ajax_load_posts function. This makes it possible for unauthenticated attackers to extract text data from password-protected posts using the boolean-based attack on the AJAX search form
Affected products
- vinod-dalvi Ivory Search – WordPress Search Plugin: before 5.5.7 — fixed in 5.5.7
How to fix
Upgrade to a fixed version: vinod-dalvi Ivory Search – WordPress Search Plugin 5.5.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/add-search-to-menu/tags/5.5.6/public/class-is-ajax.php#L45
- https://plugins.trac.wordpress.org/browser/add-search-to-menu/tags/5.5.6/public/partials/is-ajax-results.php#L57
- https://plugins.trac.wordpress.org/changeset/3145289/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/013f7c26-8348-4c54-af61-473a720a5095?source=cve
Get alerted when CVE-2024-6835 or the next vulnerability affects your stack